Flow

An NDoc Documented Class Library

Flow Namespace

Namespace hierarchy

Classes

Class | Description
ChannelControls | Control to set parameters to display the channel data
ChannelData | Class to store and access channel data.
EditColorGradient | Editor for a color gradient
FlowData2D | Class representing a 2-dimensional flow dataset
FlowViewer | The main flow viewer window.
GlyphControls | Controls that holds the parameters for the glyphs
GPUStreamlinesControls | Controls for the GPU streamlines.
MainControls | The main controls.
StreamLinesControls | Control for the evely spaced streamlines.

Structures

Structure | Description
FlowData2D.TimeStep |

Enumerations

Enumeration | Description
FlowData2D.DrawMethod | Draw methods for the glyphs
FlowData2D.IntegrationMethod | Integration Method for the streamlines
StreamLinesControls.DRAWTYPE | The draw types of the evenly spaced streamlines.


ChannelControls Class

Control to set parameters to display the channel data

For a list of all members of this type, see ChannelControls Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ChannelControls

public class ChannelControls : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

ChannelControls Members | Flow Namespace


ChannelControls Members

ChannelControls overview

Public Instance Constructors

ChannelControls Constructor Initializes a new instance of the ChannelControls class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColorGradient | Gets or sets the color gradient for the channel data.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
CurrentChannel | Gets the current channel index.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Dataset | Sets the flowdataset dataset, dates up the min/max value.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnChannelChanged | Occurs when the channel has changed
OnTFChanged | Occurs when the transfer function has changed
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ChannelControls Class | Flow Namespace


ChannelControls Constructor

Initializes a new instance of the ChannelControls class.

public ChannelControls();

See Also

ChannelControls Class | Flow Namespace


ChannelControls Properties

The properties of the ChannelControls class are listed below. For a complete list of ChannelControls class members, see the ChannelControls Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColorGradient | Gets or sets the color gradient for the channel data.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
CurrentChannel | Gets the current channel index.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Dataset | Sets the flowdataset dataset, dates up the min/max value.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ChannelControls Class | Flow Namespace


ColorGradient Property

An NDoc Documented Class Library

ChannelControls.ColorGradient Property

Gets or sets the color gradient for the channel data.

public ColorGradient {get; set;}

Property Value

The color gradient.

See Also

ChannelControls Class | Flow Namespace


CurrentChannel Property

An NDoc Documented Class Library

ChannelControls.CurrentChannel Property

Gets the current channel index.

public CurrentChannel {get;}

Property Value

The current channel.

See Also

ChannelControls Class | Flow Namespace


Dataset Property

An NDoc Documented Class Library

ChannelControls.Dataset Property

Sets the flowdataset dataset, dates up the min/max value.

public Dataset {set;}

Property Value

The dataset.

See Also

ChannelControls Class | Flow Namespace


ChannelControls Methods

The methods of the ChannelControls class are listed below. For a complete list of ChannelControls class members, see the ChannelControls Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ChannelControls Class | Flow Namespace


Method

An NDoc Documented Class Library

ChannelControls. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

ChannelControls Class | Flow Namespace


ChannelControls. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ChannelControls Class | Flow Namespace | ChannelControls. Overload List


ChannelControls Events

The events of the ChannelControls class are listed below. For a complete list of ChannelControls class members, see the ChannelControls Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnChannelChanged | Occurs when the channel has changed
OnTFChanged | Occurs when the transfer function has changed
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ChannelControls Class | Flow Namespace


ChannelControls.EventHandler Event

Occurs when the channel has changed

public event OnChannelChanged;

See Also

ChannelControls Class | Flow Namespace


ChannelControls.EventHandler Event

Occurs when the transfer function has changed

public event OnTFChanged;

See Also

ChannelControls Class | Flow Namespace


ChannelData Class

Class to store and access channel data.

For a list of all members of this type, see ChannelData Members.

System.Object
ChannelData

public class ChannelData :

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

ChannelData Members | Flow Namespace


ChannelData Members

ChannelData overview

Public Instance Constructors

ChannelData Constructor Initializes a new instance of the ChannelData class.

Public Instance Properties

Max | Gets the maximum of the channel values.
Min | Gets the minimum of the channel values.
Values | Gets the value array.
ValueTexture | Gets the value texture.

Public Instance Methods

CreateValueTexture | Creates the value texture.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInterpolatedValue | Gets the interpolated value for a given grid index coordinate.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateMinMax | Updates the minimum and maximum from the values array.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChannelData Class | Flow Namespace


ChannelData Constructor

Initializes a new instance of the ChannelData class.

public ChannelData(
FlowData2D ds
);

Parameters

FlowData2D
The dataset.

See Also

ChannelData Class | Flow Namespace


ChannelData Properties

The properties of the ChannelData class are listed below. For a complete list of ChannelData class members, see the ChannelData Members topic.

Public Instance Properties

Max | Gets the maximum of the channel values.
Min | Gets the minimum of the channel values.
Values | Gets the value array.
ValueTexture | Gets the value texture.

See Also

ChannelData Class | Flow Namespace


Max Property

An NDoc Documented Class Library

ChannelData.Max Property

Gets the maximum of the channel values.

public Max {get;}

Property Value

The maximum.

See Also

ChannelData Class | Flow Namespace


Min Property

An NDoc Documented Class Library

ChannelData.Min Property

Gets the minimum of the channel values.

public Min {get;}

Property Value

The minimum.

See Also

ChannelData Class | Flow Namespace


Values Property

An NDoc Documented Class Library

ChannelData.Values Property

Gets the value array.

public Values {get;}

Property Value

The values.

See Also

ChannelData Class | Flow Namespace


ValueTexture Property

An NDoc Documented Class Library

ChannelData.ValueTexture Property

Gets the value texture.

public ValueTexture {get;}

Property Value

The value texture.

See Also

ChannelData Class | Flow Namespace


ChannelData Methods

The methods of the ChannelData class are listed below. For a complete list of ChannelData class members, see the ChannelData Members topic.

Public Instance Methods

CreateValueTexture | Creates the value texture.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInterpolatedValue | Gets the interpolated value for a given grid index coordinate.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateMinMax | Updates the minimum and maximum from the values array.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChannelData Class | Flow Namespace


ChannelData. Method

Creates the value texture.

public void ();

See Also

ChannelData Class | Flow Namespace


ChannelData. Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void ();

Implements

IDisposable.

See Also

ChannelData Class | Flow Namespace


ChannelData. Method

Gets the interpolated value for a given grid index coordinate.

public float (
Vector2 index
);

Parameters

Vector2
The index.

Return Value

See Also

ChannelData Class | Flow Namespace


ChannelData. Method

Updates the minimum and maximum from the values array.

public void ();

See Also

ChannelData Class | Flow Namespace


EditColorGradient Class

Editor for a color gradient

For a list of all members of this type, see EditColorGradient Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EditColorGradient

public class EditColorGradient : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

EditColorGradient Members | Flow Namespace


EditColorGradient Members

EditColorGradient overview

Public Instance Constructors

EditColorGradient Constructor Initializes a new instance of the EditColorGradient class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
ColorGradient | Gets or sets the color gradient.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnTFChanged | Occurs when color gradient transfer function has changed.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EditColorGradient Class | Flow Namespace


EditColorGradient Constructor

Initializes a new instance of the EditColorGradient class.

public EditColorGradient();

See Also

EditColorGradient Class | Flow Namespace


EditColorGradient Properties

The properties of the EditColorGradient class are listed below. For a complete list of EditColorGradient class members, see the EditColorGradient Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
ColorGradient | Gets or sets the color gradient.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

EditColorGradient Class | Flow Namespace


ColorGradient Property

An NDoc Documented Class Library

EditColorGradient.ColorGradient Property

Gets or sets the color gradient.

public ColorGradient {get; set;}

Property Value

The color gradient.

See Also

EditColorGradient Class | Flow Namespace


EditColorGradient Methods

The methods of the EditColorGradient class are listed below. For a complete list of EditColorGradient class members, see the EditColorGradient Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EditColorGradient Class | Flow Namespace


Method

An NDoc Documented Class Library

EditColorGradient. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

EditColorGradient Class | Flow Namespace


EditColorGradient. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

EditColorGradient Class | Flow Namespace | EditColorGradient. Overload List


EditColorGradient Events

The events of the EditColorGradient class are listed below. For a complete list of EditColorGradient class members, see the EditColorGradient Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnTFChanged | Occurs when color gradient transfer function has changed.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

EditColorGradient Class | Flow Namespace


EditColorGradient.EventHandler Event

Occurs when color gradient transfer function has changed.

public event OnTFChanged;

See Also

EditColorGradient Class | Flow Namespace


FlowData2D Class

Class representing a 2-dimensional flow dataset

For a list of all members of this type, see FlowData2D Members.

System.Object
FlowData2D

public class FlowData2D :

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

FlowData2D Members | Flow Namespace


FlowData2D Members

FlowData2D overview

Public Instance Constructors

FlowData2D Constructor Initializes a new instance of the FlowData2D class.

Public Instance Properties

ChannelCount | Gets the number of channels.
Device | Gets the device.
DimX | Gets the X dimension.
DimY | Gets the Y dimension.
DT | Gets the DT.
Extend | Gets the extend of the dataset.
Filename | Gets the filename of the dataset.
FlowData | Gets the flow data.
GridPrimitiveCount | Gets the grid primitive count.
IndexTexture | Gets the index texture.
Max | Gets the maximum x and y grid position.
Min | Gets the minimum x and y grid position.
TimeStepCount | Gets the number of time steps.

Public Instance Methods

BuildEvenlySpacedStreamLines | Builds the evenly spaced stream lines.
BuildGPUStreamLines | Builds the GPU stream lines.
BuildIndexTexture | Builds the index texture.
CalcIndex | Calculates the index from a normalized coordinate.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RenderESStreamLines | Renders the evenly spaced stream lines.
RenderGlyphs | Renders the glyphs.
RenderGPUStreamLines | Renders the GPU stream lines.
RenderGrid | Renders the grid.
SetupGlyphsRendering | Setups the glyphs rendering.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FlowData2D Class | Flow Namespace


FlowData2D Constructor

Initializes a new instance of the FlowData2D class.

public FlowData2D(
String filename,
Device dv
);

Parameters

String
The filename of the dataset.
Device
The dv.

See Also

FlowData2D Class | Flow Namespace


FlowData2D Properties

The properties of the FlowData2D class are listed below. For a complete list of FlowData2D class members, see the FlowData2D Members topic.

Public Instance Properties

ChannelCount | Gets the number of channels.
Device | Gets the device.
DimX | Gets the X dimension.
DimY | Gets the Y dimension.
DT | Gets the DT.
Extend | Gets the extend of the dataset.
Filename | Gets the filename of the dataset.
FlowData | Gets the flow data.
GridPrimitiveCount | Gets the grid primitive count.
IndexTexture | Gets the index texture.
Max | Gets the maximum x and y grid position.
Min | Gets the minimum x and y grid position.
TimeStepCount | Gets the number of time steps.

See Also

FlowData2D Class | Flow Namespace


ChannelCount Property

An NDoc Documented Class Library

FlowData2D.ChannelCount Property

Gets the number of channels.

public ChannelCount {get;}

See Also

FlowData2D Class | Flow Namespace


Device Property

An NDoc Documented Class Library

FlowData2D.Device Property

Gets the device.

public Device {get;}

Property Value

The device.

See Also

FlowData2D Class | Flow Namespace


DimX Property

An NDoc Documented Class Library

FlowData2D.DimX Property

Gets the X dimension.

public DimX {get;}

See Also

FlowData2D Class | Flow Namespace


DimY Property

An NDoc Documented Class Library

FlowData2D.DimY Property

Gets the Y dimension.

public DimY {get;}

See Also

FlowData2D Class | Flow Namespace


DT Property

An NDoc Documented Class Library

FlowData2D.DT Property

Gets the DT.

public DT {get;}

See Also

FlowData2D Class | Flow Namespace


Extend Property

An NDoc Documented Class Library

FlowData2D.Extend Property

Gets the extend of the dataset.

public Extend {get;}

Property Value

The extend.

See Also

FlowData2D Class | Flow Namespace


Filename Property

An NDoc Documented Class Library

FlowData2D.Filename Property

Gets the filename of the dataset.

public Filename {get;}

See Also

FlowData2D Class | Flow Namespace


FlowData Property

An NDoc Documented Class Library

FlowData2D.FlowData Property

Gets the flow data.

public FlowData {get;}

Property Value

The flow data.

See Also

FlowData2D Class | Flow Namespace


GridPrimitiveCount Property

An NDoc Documented Class Library

FlowData2D.GridPrimitiveCount Property

Gets the grid primitive count.

public GridPrimitiveCount {get;}

Property Value

The grid primitive count.

See Also

FlowData2D Class | Flow Namespace


IndexTexture Property

An NDoc Documented Class Library

FlowData2D.IndexTexture Property

Gets the index texture.

public IndexTexture {get;}

Property Value

The index texture.

See Also

FlowData2D Class | Flow Namespace


Max Property

An NDoc Documented Class Library

FlowData2D.Max Property

Gets the maximum x and y grid position.

public Max {get;}

See Also

FlowData2D Class | Flow Namespace


Min Property

An NDoc Documented Class Library

FlowData2D.Min Property

Gets the minimum x and y grid position.

public Min {get;}

See Also

FlowData2D Class | Flow Namespace


TimeStepCount Property

An NDoc Documented Class Library

FlowData2D.TimeStepCount Property

Gets the number of time steps.

public TimeStepCount {get;}

See Also

FlowData2D Class | Flow Namespace


FlowData2D Methods

The methods of the FlowData2D class are listed below. For a complete list of FlowData2D class members, see the FlowData2D Members topic.

Public Instance Methods

BuildEvenlySpacedStreamLines | Builds the evenly spaced stream lines.
BuildGPUStreamLines | Builds the GPU stream lines.
BuildIndexTexture | Builds the index texture.
CalcIndex | Calculates the index from a normalized coordinate.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RenderESStreamLines | Renders the evenly spaced stream lines.
RenderGlyphs | Renders the glyphs.
RenderGPUStreamLines | Renders the GPU stream lines.
RenderGrid | Renders the grid.
SetupGlyphsRendering | Setups the glyphs rendering.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Builds the evenly spaced stream lines.

public void (
FlowData2D.IntegrationMethod method,
Int32 MaxIterations,
Single StepSize,
Single dsep,
Single dtestperc,
StreamLinesControls.DRAWTYPE drawtype
);

Parameters

FlowData2D.IntegrationMethod
The method.
Int32
The max iterations.
Single
Size of the step.
Single
The dsep.
Single
The dtestperc.
StreamLinesControls.DRAWTYPE
The drawtype.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Builds the GPU stream lines.

public void (
Effect fx,
FlowData2D.IntegrationMethod method,
Int32 steps,
Single dt,
Single density,
Boolean jitter
);

Parameters

Effect
The fx.
FlowData2D.IntegrationMethod
The method.
Int32
The steps.
Single
The dt.
Single
The density.
Boolean
if set to true [jitter].

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Builds the index texture.

public void (
Int32 resolution
);

Parameters

Int32
The resolution.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Calculates the index from a normalized coordinate.

public Vector2 (
Vector2 pos
);

Parameters

Vector2
The pos in normalized grid coordinates.

Return Value

The index.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void ();

Implements

IDisposable.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Renders the evenly spaced stream lines.

public void (
Effect fx
);

Parameters

Effect
The fx.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Renders the glyphs.

public void (
Effect fx
);

Parameters

Effect
The fx.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Renders the GPU stream lines.

public void (
Effect fx,
Single opacity
);

Parameters

Effect
The fx.
Single
The opacity.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Renders the grid.

public void (
Effect fx
);

Parameters

Effect
The fx.

See Also

FlowData2D Class | Flow Namespace


FlowData2D. Method

Setups the glyphs rendering.

public void (
Single density
);

Parameters

Single
The density.

See Also

FlowData2D Class | Flow Namespace


FlowData2D.DrawMethod Enumeration

Draw methods for the glyphs

public enum FlowData2D.DrawMethod

Members

Member Name | Description
Lines | lines
Glyphes | glyphstextures

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

Flow Namespace


FlowData2D.IntegrationMethod Enumeration

Integration Method for the streamlines

public enum FlowData2D.IntegrationMethod

Members

Member Name | Description
None | None
Euler | Euler
RungeKutter | Runge-Kutter

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

Flow Namespace


FlowData2D.TimeStep Structure

For a list of all members of this type, see FlowData2D.TimeStep Members.

System.Object
ValueType
FlowData2D.TimeStep

public struct FlowData2D.TimeStep

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

FlowData2D.TimeStep Members | Flow Namespace


FlowData2D.TimeStep Members

FlowData2D.TimeStep overview

Public Instance Constructors

FlowData2D.TimeStep Constructor

Public Instance Fields

Channels

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

FlowData2D.TimeStep Structure | Flow Namespace


FlowData2D.TimeStep Constructor

public FlowData2D.TimeStep(
Int32 channelcount
);

See Also

FlowData2D.TimeStep Structure | Flow Namespace


FlowData2D.TimeStep Fields

The fields of the FlowData2D.TimeStep structure are listed below. For a complete list of FlowData2D.TimeStep structure members, see the FlowData2D.TimeStep Members topic.

Public Instance Fields

Channels

See Also

FlowData2D.TimeStep Structure | Flow Namespace


FlowData2D.TimeStep.Channels Field

public ChannelData[] Channels;

See Also

FlowData2D.TimeStep Class | Flow Namespace


FlowViewer Class

The main flow viewer window.

For a list of all members of this type, see FlowViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
FlowViewer

public class FlowViewer : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

FlowViewer Members | Flow Namespace


FlowViewer Members

FlowViewer overview

Public Static Methods

ExternalDoRendering Do rendering.

Public Instance Constructors

FlowViewer Constructor Initializes a new instance of the FlowViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
Init3D | Inits the graphics device.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
Render | Renders this dataset.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FlowViewer Class | Flow Namespace


FlowViewer Constructor

Initializes a new instance of the FlowViewer class.

public FlowViewer();

See Also

FlowViewer Class | Flow Namespace


FlowViewer Methods

The methods of the FlowViewer class are listed below. For a complete list of FlowViewer class members, see the FlowViewer Members topic.

Public Static Methods

ExternalDoRendering Do rendering.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
Init3D | Inits the graphics device.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
Render | Renders this dataset.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FlowViewer Class | Flow Namespace


Method

An NDoc Documented Class Library

FlowViewer. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

FlowViewer Class | Flow Namespace


FlowViewer. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

FlowViewer Class | Flow Namespace | FlowViewer. Overload List


FlowViewer. Method

Do rendering.

public static void (
Object userinfo
);

Parameters

Object
The userinfo.

See Also

FlowViewer Class | Flow Namespace


FlowViewer. Method

Inits the graphics device.

public void ();

See Also

FlowViewer Class | Flow Namespace


FlowViewer. Method

Renders this dataset.

public void ();

See Also

FlowViewer Class | Flow Namespace


GlyphControls Class

Controls that holds the parameters for the glyphs

For a list of all members of this type, see GlyphControls Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GlyphControls

public class GlyphControls : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

GlyphControls Members | Flow Namespace


GlyphControls Members

GlyphControls overview

Public Instance Constructors

GlyphControls Constructor Initializes a new instance of the GlyphControls class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GlpyhDensity | Gets or sets the glpyh density.
GlyphsEnabled | Gets or sets a value indicating whether [glyphs enabled].
GlyphSize | Gets or sets the size of the glyph.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnGlyphParamChanged | Occurs when a glyph parameter has changed
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GlyphControls Class | Flow Namespace


GlyphControls Constructor

Initializes a new instance of the GlyphControls class.

public GlyphControls();

See Also

GlyphControls Class | Flow Namespace


GlyphControls Properties

The properties of the GlyphControls class are listed below. For a complete list of GlyphControls class members, see the GlyphControls Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GlpyhDensity | Gets or sets the glpyh density.
GlyphsEnabled | Gets or sets a value indicating whether [glyphs enabled].
GlyphSize | Gets or sets the size of the glyph.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GlyphControls Class | Flow Namespace


GlpyhDensity Property

An NDoc Documented Class Library

GlyphControls.GlpyhDensity Property

Gets or sets the glpyh density.

public GlpyhDensity {get; set;}

Property Value

The glpyh density.

See Also

GlyphControls Class | Flow Namespace


GlyphsEnabled Property

An NDoc Documented Class Library

GlyphControls.GlyphsEnabled Property

Gets or sets a value indicating whether [glyphs enabled].

public GlyphsEnabled {get; set;}

Property Value

true if [glyphs enabled]; otherwise, false.

See Also

GlyphControls Class | Flow Namespace


GlyphSize Property

An NDoc Documented Class Library

GlyphControls.GlyphSize Property

Gets or sets the size of the glyph.

public GlyphSize {get; set;}

Property Value

The size of the glyph.

See Also

GlyphControls Class | Flow Namespace


GlyphControls Methods

The methods of the GlyphControls class are listed below. For a complete list of GlyphControls class members, see the GlyphControls Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GlyphControls Class | Flow Namespace


Method

An NDoc Documented Class Library

GlyphControls. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

GlyphControls Class | Flow Namespace


GlyphControls. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GlyphControls Class | Flow Namespace | GlyphControls. Overload List


GlyphControls Events

The events of the GlyphControls class are listed below. For a complete list of GlyphControls class members, see the GlyphControls Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnGlyphParamChanged | Occurs when a glyph parameter has changed
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

GlyphControls Class | Flow Namespace


GlyphControls.EventHandler Event

Occurs when a glyph parameter has changed

public event OnGlyphParamChanged;

See Also

GlyphControls Class | Flow Namespace


GPUStreamlinesControls Class

Controls for the GPU streamlines.

For a list of all members of this type, see GPUStreamlinesControls Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GPUStreamlinesControls

public class GPUStreamlinesControls : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

GPUStreamlinesControls Members | Flow Namespace


GPUStreamlinesControls Members

GPUStreamlinesControls overview

Public Instance Constructors

GPUStreamlinesControls Constructor Initializes a new instance of the GPUStreamlinesControls class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Density | Gets or sets the density.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
Jitter | Gets or sets a value indicating whether this GPUStreamlinesControls is jitter.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
Method | Gets or sets the method.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity | Gets or sets the opacity.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StepCount | Gets or sets the step count.
StepSize | Gets or sets the size of the step.
StreamLinesEnabled |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnGPUParamChanged | Occurs when any parameter has changed.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GPUStreamlinesControls Class | Flow Namespace


GPUStreamlinesControls Constructor

Initializes a new instance of the GPUStreamlinesControls class.

public GPUStreamlinesControls();

See Also

GPUStreamlinesControls Class | Flow Namespace


GPUStreamlinesControls Properties

The properties of the GPUStreamlinesControls class are listed below. For a complete list of GPUStreamlinesControls class members, see the GPUStreamlinesControls Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Density | Gets or sets the density.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
Jitter | Gets or sets a value indicating whether this GPUStreamlinesControls is jitter.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
Method | Gets or sets the method.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity | Gets or sets the opacity.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StepCount | Gets or sets the step count.
StepSize | Gets or sets the size of the step.
StreamLinesEnabled |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GPUStreamlinesControls Class | Flow Namespace


Density Property

An NDoc Documented Class Library

GPUStreamlinesControls.Density Property

Gets or sets the density.

public Density {get; set;}

Property Value

The density.

See Also

GPUStreamlinesControls Class | Flow Namespace


Jitter Property

An NDoc Documented Class Library

GPUStreamlinesControls.Jitter Property

Gets or sets a value indicating whether this GPUStreamlinesControls is jitter.

public Jitter {get; set;}

Property Value

true if jitter; otherwise, false.

See Also

GPUStreamlinesControls Class | Flow Namespace


Method Property

An NDoc Documented Class Library

GPUStreamlinesControls.Method Property

Gets or sets the method.

public Method {get; set;}

Property Value

The method.

See Also

GPUStreamlinesControls Class | Flow Namespace


Opacity Property

An NDoc Documented Class Library

GPUStreamlinesControls.Opacity Property

Gets or sets the opacity.

public Opacity {get; set;}

Property Value

The opacity.

See Also

GPUStreamlinesControls Class | Flow Namespace


StepCount Property

An NDoc Documented Class Library

GPUStreamlinesControls.StepCount Property

Gets or sets the step count.

public StepCount {get; set;}

Property Value

The step count.

See Also

GPUStreamlinesControls Class | Flow Namespace


StepSize Property

An NDoc Documented Class Library

GPUStreamlinesControls.StepSize Property

Gets or sets the size of the step.

public StepSize {get; set;}

Property Value

The size of the step.

See Also

GPUStreamlinesControls Class | Flow Namespace


StreamLinesEnabled Property

An NDoc Documented Class Library

GPUStreamlinesControls.StreamLinesEnabled Property

public StreamLinesEnabled {get; set;}

See Also

GPUStreamlinesControls Class | Flow Namespace


GPUStreamlinesControls Methods

The methods of the GPUStreamlinesControls class are listed below. For a complete list of GPUStreamlinesControls class members, see the GPUStreamlinesControls Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GPUStreamlinesControls Class | Flow Namespace


Method

An NDoc Documented Class Library

GPUStreamlinesControls. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

GPUStreamlinesControls Class | Flow Namespace


GPUStreamlinesControls. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GPUStreamlinesControls Class | Flow Namespace | GPUStreamlinesControls. Overload List


GPUStreamlinesControls Events

The events of the GPUStreamlinesControls class are listed below. For a complete list of GPUStreamlinesControls class members, see the GPUStreamlinesControls Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnGPUParamChanged | Occurs when any parameter has changed.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

GPUStreamlinesControls Class | Flow Namespace


GPUStreamlinesControls.EventHandler Event

Occurs when any parameter has changed.

public event OnGPUParamChanged;

See Also

GPUStreamlinesControls Class | Flow Namespace


MainControls Class

The main controls.

For a list of all members of this type, see MainControls Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
MainControls

public class MainControls : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

MainControls Members | Flow Namespace


MainControls Members

MainControls overview

Public Instance Constructors

MainControls Constructor Initializes a new instance of the MainControls class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSet | Sets the data set from which the information is displayed.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IndexSize | Gets or sets the size of the index texture.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScreenShotFileName | Gets the name of the screen shot file.
ScreenShotXRes | Gets the horizontal resolution of the screen shot.
ScreenShotYRes | Gets the vertical resolution of the screen shot.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnIndexSizeChanged | Occurs when index size has changed.
OnOpenDataset | Occurs when open button has been clicked.
OnScreenShot | Occurs when screen shot button has been clicked.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MainControls Class | Flow Namespace


MainControls Constructor

Initializes a new instance of the MainControls class.

public MainControls();

See Also

MainControls Class | Flow Namespace


MainControls Properties

The properties of the MainControls class are listed below. For a complete list of MainControls class members, see the MainControls Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSet | Sets the data set from which the information is displayed.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IndexSize | Gets or sets the size of the index texture.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScreenShotFileName | Gets the name of the screen shot file.
ScreenShotXRes | Gets the horizontal resolution of the screen shot.
ScreenShotYRes | Gets the vertical resolution of the screen shot.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

MainControls Class | Flow Namespace


DataSet Property

An NDoc Documented Class Library

MainControls.DataSet Property

Sets the data set from which the information is displayed.

public DataSet {set;}

Property Value

The data set.

See Also

MainControls Class | Flow Namespace


IndexSize Property

An NDoc Documented Class Library

MainControls.IndexSize Property

Gets or sets the size of the index texture.

public IndexSize {get; set;}

Property Value

The size of the index texture.

See Also

MainControls Class | Flow Namespace


ScreenShotFileName Property

An NDoc Documented Class Library

MainControls.ScreenShotFileName Property

Gets the name of the screen shot file.

public ScreenShotFileName {get;}

Property Value

The name of the screen shot file.

See Also

MainControls Class | Flow Namespace


ScreenShotXRes Property

An NDoc Documented Class Library

MainControls.ScreenShotXRes Property

Gets the horizontal resolution of the screen shot.

public ScreenShotXRes {get;}

Property Value

The screen shot width.

See Also

MainControls Class | Flow Namespace


ScreenShotYRes Property

An NDoc Documented Class Library

MainControls.ScreenShotYRes Property

Gets the vertical resolution of the screen shot.

public ScreenShotYRes {get;}

Property Value

The screen shot height.

See Also

MainControls Class | Flow Namespace


MainControls Methods

The methods of the MainControls class are listed below. For a complete list of MainControls class members, see the MainControls Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MainControls Class | Flow Namespace


Method

An NDoc Documented Class Library

MainControls. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

MainControls Class | Flow Namespace


MainControls. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

MainControls Class | Flow Namespace | MainControls. Overload List


MainControls Events

The events of the MainControls class are listed below. For a complete list of MainControls class members, see the MainControls Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnIndexSizeChanged | Occurs when index size has changed.
OnOpenDataset | Occurs when open button has been clicked.
OnScreenShot | Occurs when screen shot button has been clicked.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

MainControls Class | Flow Namespace


MainControls.EventHandler Event

Occurs when index size has changed.

public event OnIndexSizeChanged;

See Also

MainControls Class | Flow Namespace


MainControls.EventHandler Event

Occurs when open button has been clicked.

public event OnOpenDataset;

See Also

MainControls Class | Flow Namespace


MainControls.EventHandler Event

Occurs when screen shot button has been clicked.

public event OnScreenShot;

See Also

MainControls Class | Flow Namespace


StreamLinesControls Class

Control for the evely spaced streamlines.

For a list of all members of this type, see StreamLinesControls Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
StreamLinesControls

public class StreamLinesControls : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

StreamLinesControls Members | Flow Namespace


StreamLinesControls Members

StreamLinesControls overview

Public Instance Constructors

StreamLinesControls Constructor Initializes a new instance of the StreamLinesControls class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DrawType | Gets or sets the type of the draw of the stream lines.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
Iterations | Gets or sets the iterations.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
Method | Gets or sets the integration method.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SepDistance | Gets or sets the sep distance.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StepSize | Gets or sets the size of the step.
StreamLinesEnabled | Gets or sets a value indicating whether [stream lines enabled].
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
TestDistance | Gets or sets the test distance.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnESSParamChanged | Occurs when any parameter has changed
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StreamLinesControls Class | Flow Namespace


StreamLinesControls Constructor

Initializes a new instance of the StreamLinesControls class.

public StreamLinesControls();

See Also

StreamLinesControls Class | Flow Namespace


StreamLinesControls Properties

The properties of the StreamLinesControls class are listed below. For a complete list of StreamLinesControls class members, see the StreamLinesControls Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DrawType | Gets or sets the type of the draw of the stream lines.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
Iterations | Gets or sets the iterations.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
Method | Gets or sets the integration method.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SepDistance | Gets or sets the sep distance.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StepSize | Gets or sets the size of the step.
StreamLinesEnabled | Gets or sets a value indicating whether [stream lines enabled].
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
TestDistance | Gets or sets the test distance.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

StreamLinesControls Class | Flow Namespace


StreamLinesControls.DRAWTYPE Enumeration

The draw types of the evenly spaced streamlines.

public enum StreamLinesControls.DRAWTYPE

Members

Member Name | Description
NONE | None
NORMAL | Normal lines.
TAPERING | Tapering.
GLYPHMAPPING | Glpyphmapping.
TEXTURE | Texturing.

Requirements

Namespace: Flow

Assembly: Flow (in Flow.exe)

See Also

Flow Namespace


Iterations Property

An NDoc Documented Class Library

StreamLinesControls.Iterations Property

Gets or sets the iterations.

public Iterations {get; set;}

Property Value

The iterations.

See Also

StreamLinesControls Class | Flow Namespace


Method Property

An NDoc Documented Class Library

StreamLinesControls.Method Property

Gets or sets the integration method.

public Method {get; set;}

Property Value

The method.

See Also

StreamLinesControls Class | Flow Namespace


SepDistance Property

An NDoc Documented Class Library

StreamLinesControls.SepDistance Property

Gets or sets the sep distance.

public SepDistance {get; set;}

Property Value

The sep distance.

See Also

StreamLinesControls Class | Flow Namespace


StepSize Property

An NDoc Documented Class Library

StreamLinesControls.StepSize Property

Gets or sets the size of the step.

public StepSize {get; set;}

Property Value

The size of the step.

See Also

StreamLinesControls Class | Flow Namespace


StreamLinesEnabled Property

An NDoc Documented Class Library

StreamLinesControls.StreamLinesEnabled Property

Gets or sets a value indicating whether [stream lines enabled].

public StreamLinesEnabled {get; set;}

Property Value

true if [stream lines enabled]; otherwise, false.

See Also

StreamLinesControls Class | Flow Namespace


TestDistance Property

An NDoc Documented Class Library

StreamLinesControls.TestDistance Property

Gets or sets the test distance.

public TestDistance {get; set;}

Property Value

The test distance.

See Also

StreamLinesControls Class | Flow Namespace


StreamLinesControls Methods

The methods of the StreamLinesControls class are listed below. For a complete list of StreamLinesControls class members, see the StreamLinesControls Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StreamLinesControls Class | Flow Namespace


Method

An NDoc Documented Class Library

StreamLinesControls. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

StreamLinesControls Class | Flow Namespace


StreamLinesControls. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

StreamLinesControls Class | Flow Namespace | StreamLinesControls. Overload List


StreamLinesControls Events

The events of the StreamLinesControls class are listed below. For a complete list of StreamLinesControls class members, see the StreamLinesControls Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnESSParamChanged | Occurs when any parameter has changed
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

StreamLinesControls Class | Flow Namespace


StreamLinesControls.EventHandler Event

Occurs when any parameter has changed

public event OnESSParamChanged;

See Also

StreamLinesControls Class | Flow Namespace


VisControls

An NDoc Documented Class Library

VisControls Namespace

Namespace hierarchy

Classes

Class | Description
Camera |
GlowingRadioButton |
GroupBoxDrop |
GroupBoxDropContainer |
Keyboard |
OffscreenRT |
ScreenshotRenderer |
ShaderViewer |
Transfer2D |
VisSwapChain |

Delegates

Delegate | Description
ScreenshotRenderer.DoRendering |

Enumerations

Enumeration | Description
Keyboard.VirtualKeyStates |


Camera Class

For a list of all members of this type, see Camera Members.

System.Object
Camera

public class Camera

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

Camera Members | VisControls Namespace


Camera Members

Camera overview

Public Instance Constructors

Camera Constructor Initializes a new instance of the Camera class.

Public Instance Properties

Far
Near
Position
Proj
Rotation
View
ViewDir
ViewRight
ViewUp
YawPitchRoll

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
flip |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
lookAt |
move |
moveOriented |
orthoProj |
perspectiveProj |
perspectiveProjEx |
perspectiveProjFov |
reset |
rotate |
rotateOriented |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Camera Class | VisControls Namespace


Camera Constructor

Initializes a new instance of the Camera class.

public Camera();

See Also

Camera Class | VisControls Namespace


Camera Properties

The properties of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Public Instance Properties

Far
Near
Position
Proj
Rotation
View
ViewDir
ViewRight
ViewUp
YawPitchRoll

See Also

Camera Class | VisControls Namespace


Far Property

An NDoc Documented Class Library

Camera.Far Property

public Far {get;}

See Also

Camera Class | VisControls Namespace


Near Property

An NDoc Documented Class Library

Camera.Near Property

public Near {get;}

See Also

Camera Class | VisControls Namespace


Position Property

An NDoc Documented Class Library

Camera.Position Property

public Position {get; set;}

See Also

Camera Class | VisControls Namespace


Proj Property

An NDoc Documented Class Library

Camera.Proj Property

public Proj {get; set;}

See Also

Camera Class | VisControls Namespace


Rotation Property

An NDoc Documented Class Library

Camera.Rotation Property

public Rotation {get; set;}

See Also

Camera Class | VisControls Namespace


View Property

An NDoc Documented Class Library

Camera.View Property

public View {get; set;}

See Also

Camera Class | VisControls Namespace


ViewDir Property

An NDoc Documented Class Library

Camera.ViewDir Property

public ViewDir {get;}

See Also

Camera Class | VisControls Namespace


ViewRight Property

An NDoc Documented Class Library

Camera.ViewRight Property

public ViewRight {get;}

See Also

Camera Class | VisControls Namespace


ViewUp Property

An NDoc Documented Class Library

Camera.ViewUp Property

public ViewUp {get;}

See Also

Camera Class | VisControls Namespace


YawPitchRoll Property

An NDoc Documented Class Library

Camera.YawPitchRoll Property

public YawPitchRoll {get;}

See Also

Camera Class | VisControls Namespace


Camera Methods

The methods of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
flip |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
lookAt |
move |
moveOriented |
orthoProj |
perspectiveProj |
perspectiveProjEx |
perspectiveProjFov |
reset |
rotate |
rotateOriented |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Camera Class | VisControls Namespace


Camera. Method

public void ();

See Also

Camera Class | VisControls Namespace


Camera. Method

public void (
Vector3 target,
Vector3 up
);

See Also

Camera Class | VisControls Namespace


Camera. Method

public void (
Vector3 dp
);

See Also

Camera Class | VisControls Namespace


Camera. Method

public void (
Single widht,
Single height,
Single near,
Single far
);

See Also

Camera Class | VisControls Namespace


Camera. Method

public void (
Single width,
Single height,
Single near,
Single far
);

See Also

Camera Class | VisControls Namespace


Camera. Method

public void (
Single fovy,
Single aspect,
Single near,
Single far
);

See Also

Camera Class | VisControls Namespace


Camera. Method

public void (
Vector3 ang
);

See Also

Camera Class | VisControls Namespace


GlowingRadioButton Class

For a list of all members of this type, see GlowingRadioButton Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
RadioButton
GlowingRadioButton

public class GlowingRadioButton : RadioButton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

GlowingRadioButton Members | VisControls Namespace


GlowingRadioButton Members

GlowingRadioButton overview

Public Instance Constructors

GlowingRadioButton Constructor Initializes a new instance of the GlowingRadioButton class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Appearance (inherited from RadioButton) | Gets or sets a value determining the appearance of the RadioButton.
AutoCheck (inherited from RadioButton) | Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked.
AutoEllipsis (inherited from ButtonBase) | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from ButtonBase) | Gets or sets a value that indicates whether the control resizes based on its contents.
BackColor (inherited from ButtonBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckAlign (inherited from RadioButton) | Gets or sets the location of the check box portion of the RadioButton.
Checked (inherited from RadioButton) | Gets or sets a value indicating whether the control is checked.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatAppearance (inherited from ButtonBase) | Gets the appearance of the border and the colors used to indicate check state and mouse state.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GlowColor |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageKey (inherited from ButtonBase) | Gets or sets the key accessor for the image in the ImageList.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from RadioButton) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ButtonBase) |
TextAlign (inherited from RadioButton) | Gets or sets the alignment of the text on the RadioButton control.
TextImageRelation (inherited from ButtonBase) | Gets or sets the position of text and image relative to each other.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseCompatibleTextRendering (inherited from ButtonBase) | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI).
UseMnemonic (inherited from ButtonBase) | Gets or sets a value indicating whether an ampersand (&) is included in the text of the control.
UseVisualStyleBackColor (inherited from ButtonBase) | Gets or sets a value that determines if the background is drawn using visual styles, if supported.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from ButtonBase) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformClick (inherited from RadioButton) | Generates a Click event for the control, simulating a click by a user.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from RadioButton) | Overrides the ToString method.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AppearanceChanged (inherited from RadioButton) | Occurs when the Appearance property value changes.
AutoSizeChanged (inherited from ButtonBase) | Occurs when the value of the AutoSize property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
CheckedChanged (inherited from RadioButton) | Occurs when the value of the Checked property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from RadioButton) | Occurs when the user double-clicks the RadioButton control.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) | Occurs when the ImeMode property is changed. This event is not relevant for this class.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from RadioButton) | Occurs when the user double-clicks the RadioButton control with the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from RadioButton) | Overrides CreateParams.
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from RadioButton) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
CreateAccessibilityInstance (inherited from RadioButton) | Creates a new accessibility object for the RadioButton control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded. Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged |
OnClick (inherited from RadioButton) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from RadioButton) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) | Raises the GotFocus event.
OnHandleCreated (inherited from RadioButton) | Overrides the OnHandleCreated method.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) | Raises the OnKeyUp event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) | Raises the OnLostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from ButtonBase) | Raises the OnMouseDown event.
OnMouseEnter (inherited from ButtonBase) | Raises the OnMouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) | Raises the OnMouseLeave event.
OnMouseMove (inherited from ButtonBase) | Raises the OnMouseMove event.
OnMouseUp (inherited from RadioButton) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from Control) | Raises the PaddingChanged event.
OnPaint (inherited from ButtonBase) | Raises the OnPaint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) | Resets the Button control to the state before it is pressed and redraws it.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
ScaleCore (inherited from Control) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ButtonBase) |

Protected Internal Instance Properties

IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from RadioButton) | Overrides the ProcessMnemonic method.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GlowingRadioButton Class | VisControls Namespace


GlowingRadioButton Constructor

Initializes a new instance of the GlowingRadioButton class.

public GlowingRadioButton();

See Also

GlowingRadioButton Class | VisControls Namespace


GlowingRadioButton Properties

The properties of the GlowingRadioButton class are listed below. For a complete list of GlowingRadioButton class members, see the GlowingRadioButton Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Appearance (inherited from RadioButton) | Gets or sets a value determining the appearance of the RadioButton.
AutoCheck (inherited from RadioButton) | Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked.
AutoEllipsis (inherited from ButtonBase) | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from ButtonBase) | Gets or sets a value that indicates whether the control resizes based on its contents.
BackColor (inherited from ButtonBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckAlign (inherited from RadioButton) | Gets or sets the location of the check box portion of the RadioButton.
Checked (inherited from RadioButton) | Gets or sets a value indicating whether the control is checked.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatAppearance (inherited from ButtonBase) | Gets the appearance of the border and the colors used to indicate check state and mouse state.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GlowColor |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageKey (inherited from ButtonBase) | Gets or sets the key accessor for the image in the ImageList.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from RadioButton) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ButtonBase) |
TextAlign (inherited from RadioButton) | Gets or sets the alignment of the text on the RadioButton control.
TextImageRelation (inherited from ButtonBase) | Gets or sets the position of text and image relative to each other.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseCompatibleTextRendering (inherited from ButtonBase) | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI).
UseMnemonic (inherited from ButtonBase) | Gets or sets a value indicating whether an ampersand (&) is included in the text of the control.
UseVisualStyleBackColor (inherited from ButtonBase) | Gets or sets a value that determines if the background is drawn using visual styles, if supported.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from RadioButton) | Overrides CreateParams.
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from RadioButton) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.

Protected Internal Instance Properties

IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GlowingRadioButton Class | VisControls Namespace


GlowColor Property

An NDoc Documented Class Library

GlowingRadioButton.GlowColor Property

public GlowColor {get; set;}

See Also

GlowingRadioButton Class | VisControls Namespace


GlowingRadioButton Methods

The methods of the GlowingRadioButton class are listed below. For a complete list of GlowingRadioButton class members, see the GlowingRadioButton Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from ButtonBase) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformClick (inherited from RadioButton) | Generates a Click event for the control, simulating a click by a user.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from RadioButton) | Overrides the ToString method.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
CreateAccessibilityInstance (inherited from RadioButton) | Creates a new accessibility object for the RadioButton control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded. Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged |
OnClick (inherited from RadioButton) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from RadioButton) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) | Raises the GotFocus event.
OnHandleCreated (inherited from RadioButton) | Overrides the OnHandleCreated method.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) | Raises the OnKeyUp event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) | Raises the OnLostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from ButtonBase) | Raises the OnMouseDown event.
OnMouseEnter (inherited from ButtonBase) | Raises the OnMouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) | Raises the OnMouseLeave event.
OnMouseMove (inherited from ButtonBase) | Raises the OnMouseMove event.
OnMouseUp (inherited from RadioButton) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from Control) | Raises the PaddingChanged event.
OnPaint (inherited from ButtonBase) | Raises the OnPaint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) | Resets the Button control to the state before it is pressed and redraws it.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
ScaleCore (inherited from Control) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ButtonBase) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from RadioButton) | Overrides the ProcessMnemonic method.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GlowingRadioButton Class | VisControls Namespace


GlowingRadioButton. Method

protected override void (
EventArgs e
);

See Also

GlowingRadioButton Class | VisControls Namespace


GroupBoxDrop Class

For a list of all members of this type, see GroupBoxDrop Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GroupBoxDrop

public class GroupBoxDrop : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

GroupBoxDrop Members | VisControls Namespace


GroupBoxDrop Members

GroupBoxDrop overview

Public Instance Constructors

GroupBoxDrop Constructor

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Content |
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DropState |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Title |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DropStateChanged |
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GroupBoxDrop Class | VisControls Namespace


GroupBoxDrop Constructor

public GroupBoxDrop(
Control content,
String title
);

See Also

GroupBoxDrop Class | VisControls Namespace


GroupBoxDrop Properties

The properties of the GroupBoxDrop class are listed below. For a complete list of GroupBoxDrop class members, see the GroupBoxDrop Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Content |
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DropState |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Title |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GroupBoxDrop Class | VisControls Namespace


Content Property

An NDoc Documented Class Library

GroupBoxDrop.Content Property

public Content {get;}

See Also

GroupBoxDrop Class | VisControls Namespace


DropState Property

An NDoc Documented Class Library

GroupBoxDrop.DropState Property

public DropState {get; set;}

See Also

GroupBoxDrop Class | VisControls Namespace


Title Property

An NDoc Documented Class Library

GroupBoxDrop.Title Property

public Title {get; set;}

See Also

GroupBoxDrop Class | VisControls Namespace


GroupBoxDrop Methods

The methods of the GroupBoxDrop class are listed below. For a complete list of GroupBoxDrop class members, see the GroupBoxDrop Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GroupBoxDrop Class | VisControls Namespace


Method

An NDoc Documented Class Library

GroupBoxDrop. Method

Overload List

Inherited from Component.

public void ();

protected override void (Boolean);

See Also

GroupBoxDrop Class | VisControls Namespace


GroupBoxDrop. Method (Boolean)

protected override void (
Boolean disposing
);

See Also

GroupBoxDrop Class | VisControls Namespace | GroupBoxDrop. Overload List


GroupBoxDrop Events

The events of the GroupBoxDrop class are listed below. For a complete list of GroupBoxDrop class members, see the GroupBoxDrop Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DropStateChanged |
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

GroupBoxDrop Class | VisControls Namespace


GroupBoxDrop.EventHandler Event

public event DropStateChanged;

See Also

GroupBoxDrop Class | VisControls Namespace


GroupBoxDropContainer Class

For a list of all members of this type, see GroupBoxDropContainer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GroupBoxDropContainer

public class GroupBoxDropContainer : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

GroupBoxDropContainer Members | VisControls Namespace


GroupBoxDropContainer Members

GroupBoxDropContainer overview

Public Instance Constructors

GroupBoxDropContainer Constructor Initializes a new instance of the GroupBoxDropContainer class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DropCount |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddDrop |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDrop |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveDrop |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GroupBoxDropContainer Class | VisControls Namespace


GroupBoxDropContainer Constructor

Initializes a new instance of the GroupBoxDropContainer class.

public GroupBoxDropContainer();

See Also

GroupBoxDropContainer Class | VisControls Namespace


GroupBoxDropContainer Properties

The properties of the GroupBoxDropContainer class are listed below. For a complete list of GroupBoxDropContainer class members, see the GroupBoxDropContainer Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DropCount |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GroupBoxDropContainer Class | VisControls Namespace


DropCount Property

An NDoc Documented Class Library

GroupBoxDropContainer.DropCount Property

public DropCount {get;}

See Also

GroupBoxDropContainer Class | VisControls Namespace


GroupBoxDropContainer Methods

The methods of the GroupBoxDropContainer class are listed below. For a complete list of GroupBoxDropContainer class members, see the GroupBoxDropContainer Members topic.

Public Instance Methods

AddDrop |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDrop |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveDrop |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GroupBoxDropContainer Class | VisControls Namespace


GroupBoxDropContainer. Method

public void (
GroupBoxDrop box
);

See Also

GroupBoxDropContainer Class | VisControls Namespace


Method

An NDoc Documented Class Library

GroupBoxDropContainer. Method

Overload List

Inherited from Component.

public void ();

protected override void (Boolean);

See Also

GroupBoxDropContainer Class | VisControls Namespace


GroupBoxDropContainer. Method (Boolean)

protected override void (
Boolean disposing
);

See Also

GroupBoxDropContainer Class | VisControls Namespace | GroupBoxDropContainer. Overload List


GroupBoxDropContainer. Method

public GroupBoxDrop (
Int32 i
);

See Also

GroupBoxDropContainer Class | VisControls Namespace


GroupBoxDropContainer. Method

public void (
Int32 i
);

See Also

GroupBoxDropContainer Class | VisControls Namespace


Keyboard Class

For a list of all members of this type, see Keyboard Members.

System.Object
Keyboard

public class Keyboard

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

Keyboard Members | VisControls Namespace


Keyboard Members

Keyboard overview

Public Static Methods

IsKeyPressed

Public Instance Constructors

Keyboard Constructor Initializes a new instance of the Keyboard class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Keyboard Class | VisControls Namespace


Keyboard Constructor

Initializes a new instance of the Keyboard class.

public Keyboard();

See Also

Keyboard Class | VisControls Namespace


Keyboard Methods

The methods of the Keyboard class are listed below. For a complete list of Keyboard class members, see the Keyboard Members topic.

Public Static Methods

IsKeyPressed

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Keyboard Class | VisControls Namespace


Keyboard. Method

public static bool (
Keyboard.VirtualKeyStates testKey
);

See Also

Keyboard Class | VisControls Namespace


Keyboard.VirtualKeyStates Enumeration

public enum Keyboard.VirtualKeyStates

Members

Member Name | Description
VK_LBUTTON |
VK_RBUTTON |
VK_CANCEL |
VK_MBUTTON |
VK_XBUTTON1 |
VK_XBUTTON2 |
VK_BACK |
VK_TAB |
VK_CLEAR |
VK_RETURN |
VK_SHIFT |
VK_CONTROL |
VK_MENU |
VK_PAUSE |
VK_CAPITAL |
VK_KANA |
VK_HANGEUL |
VK_HANGUL |
VK_JUNJA |
VK_FINAL |
VK_HANJA |
VK_KANJI |
VK_ESCAPE |
VK_CONVERT |
VK_NONCONVERT |
VK_ACCEPT |
VK_MODECHANGE |
VK_SPACE |
VK_PRIOR |
VK_NEXT |
VK_END |
VK_HOME |
VK_LEFT |
VK_UP |
VK_RIGHT |
VK_DOWN |
VK_SELECT |
VK_PRINT |
VK_EXECUTE |
VK_SNAPSHOT |
VK_INSERT |
VK_DELETE |
VK_HELP |
VK_LWIN |
VK_RWIN |
VK_APPS |
VK_SLEEP |
VK_NUMPAD0 |
VK_NUMPAD1 |
VK_NUMPAD2 |
VK_NUMPAD3 |
VK_NUMPAD4 |
VK_NUMPAD5 |
VK_NUMPAD6 |
VK_NUMPAD7 |
VK_NUMPAD8 |
VK_NUMPAD9 |
VK_MULTIPLY |
VK_ADD |
VK_SEPARATOR |
VK_SUBTRACT |
VK_DECIMAL |
VK_DIVIDE |
VK_F1 |
VK_F2 |
VK_F3 |
VK_F4 |
VK_F5 |
VK_F6 |
VK_F7 |
VK_F8 |
VK_F9 |
VK_F10 |
VK_F11 |
VK_F12 |
VK_F13 |
VK_F14 |
VK_F15 |
VK_F16 |
VK_F17 |
VK_F18 |
VK_F19 |
VK_F20 |
VK_F21 |
VK_F22 |
VK_F23 |
VK_F24 |
VK_NUMLOCK |
VK_SCROLL |
VK_OEM_NEC_EQUAL |
VK_OEM_FJ_JISHO |
VK_OEM_FJ_MASSHOU |
VK_OEM_FJ_TOUROKU |
VK_OEM_FJ_LOYA |
VK_OEM_FJ_ROYA |
VK_LSHIFT |
VK_RSHIFT |
VK_LCONTROL |
VK_RCONTROL |
VK_LMENU |
VK_RMENU |
VK_BROWSER_BACK |
VK_BROWSER_FORWARD |
VK_BROWSER_REFRESH |
VK_BROWSER_STOP |
VK_BROWSER_SEARCH |
VK_BROWSER_FAVORITES |
VK_BROWSER_HOME |
VK_VOLUME_MUTE |
VK_VOLUME_DOWN |
VK_VOLUME_UP |
VK_MEDIA_NEXT_TRACK |
VK_MEDIA_PREV_TRACK |
VK_MEDIA_STOP |
VK_MEDIA_PLAY_PAUSE |
VK_LAUNCH_MAIL |
VK_LAUNCH_MEDIA_SELECT |
VK_LAUNCH_APP1 |
VK_LAUNCH_APP2 |
VK_OEM_1 |
VK_OEM_PLUS |
VK_OEM_COMMA |
VK_OEM_MINUS |
VK_OEM_PERIOD |
VK_OEM_2 |
VK_OEM_3 |
VK_OEM_4 |
VK_OEM_5 |
VK_OEM_6 |
VK_OEM_7 |
VK_OEM_8 |
VK_OEM_AX |
VK_OEM_102 |
VK_ICO_HELP |
VK_ICO_00 |
VK_PROCESSKEY |
VK_ICO_CLEAR |
VK_PACKET |
VK_OEM_RESET |
VK_OEM_JUMP |
VK_OEM_PA1 |
VK_OEM_PA2 |
VK_OEM_PA3 |
VK_OEM_WSCTRL |
VK_OEM_CUSEL |
VK_OEM_ATTN |
VK_OEM_FINISH |
VK_OEM_COPY |
VK_OEM_AUTO |
VK_OEM_ENLW |
VK_OEM_BACKTAB |
VK_ATTN |
VK_CRSEL |
VK_EXSEL |
VK_EREOF |
VK_PLAY |
VK_ZOOM |
VK_NONAME |
VK_PA1 |
VK_OEM_CLEAR |

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

VisControls Namespace


OffscreenRT Class

For a list of all members of this type, see OffscreenRT Members.

System.Object
OffscreenRT

public class OffscreenRT :

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

OffscreenRT Members | VisControls Namespace


OffscreenRT Members

OffscreenRT overview

Public Instance Constructors

OffscreenRT Constructor

Public Instance Methods

Dispose |
EndRender |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetGPUSurface |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockedData |
GetOffscreenSurface |
GetType (inherited from Object) | Gets the Type of the current instance.
GetXl |
GetYl |
Lock |
SetSize |
StartRender |
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock |
UpdateGPUSurface |
UpdateOffscreenSurface |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OffscreenRT Class | VisControls Namespace


OffscreenRT Constructor

public OffscreenRT(
Device device,
Int32 xl,
Int32 yl,
Format format,
Boolean autolock,
Boolean autorestore,
Boolean autoupdate
);

See Also

OffscreenRT Class | VisControls Namespace


OffscreenRT Methods

The methods of the OffscreenRT class are listed below. For a complete list of OffscreenRT class members, see the OffscreenRT Members topic.

Public Instance Methods

Dispose |
EndRender |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetGPUSurface |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockedData |
GetOffscreenSurface |
GetType (inherited from Object) | Gets the Type of the current instance.
GetXl |
GetYl |
Lock |
SetSize |
StartRender |
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock |
UpdateGPUSurface |
UpdateOffscreenSurface |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OffscreenRT Class | VisControls Namespace


OffscreenRT. Method

public void ();

Implements

IDisposable.

See Also

OffscreenRT Class | VisControls Namespace


OffscreenRT. Method

public void ();

See Also

OffscreenRT Class | VisControls Namespace


OffscreenRT. Method

public Texture ();

See Also

OffscreenRT Class | VisControls Namespace


OffscreenRT. Method

public GraphicsStream ();

See Also

OffscreenRT Class | VisControls Namespace


OffscreenRT. Method

public int ();

See Also

OffscreenRT Class | VisControls Namespace


OffscreenRT. Method

public void (
Int32 xl,
Int32 yl
);

See Also

OffscreenRT Class | VisControls Namespace


ScreenshotRenderer Class

For a list of all members of this type, see ScreenshotRenderer Members.

System.Object
ScreenshotRenderer

public class ScreenshotRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

ScreenshotRenderer Members | VisControls Namespace


ScreenshotRenderer Members

ScreenshotRenderer overview

Public Static Methods

SaveSreenshot

Public Instance Constructors

ScreenshotRenderer Constructor Initializes a new instance of the ScreenshotRenderer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScreenshotRenderer Class | VisControls Namespace


ScreenshotRenderer Constructor

Initializes a new instance of the ScreenshotRenderer class.

public ScreenshotRenderer();

See Also

ScreenshotRenderer Class | VisControls Namespace


ScreenshotRenderer Methods

The methods of the ScreenshotRenderer class are listed below. For a complete list of ScreenshotRenderer class members, see the ScreenshotRenderer Members topic.

Public Static Methods

SaveSreenshot

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScreenshotRenderer Class | VisControls Namespace


ScreenshotRenderer. Method

public static void (
Device dv,
Int32 width,
Int32 height,
String filename,
ScreenshotRenderer.DoRendering renderfunc,
Object userinfo
);

See Also

ScreenshotRenderer Class | VisControls Namespace


ScreenshotRenderer.DoRendering Delegate

public delegate void ScreenshotRenderer.DoRendering(
Object userinfo
);

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

VisControls Namespace


ShaderViewer Class

For a list of all members of this type, see ShaderViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ShaderViewer

public class ShaderViewer : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

ShaderViewer Members | VisControls Namespace


ShaderViewer Members

ShaderViewer overview

Public Instance Constructors

ShaderViewer Constructor Initializes a new instance of the ShaderViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
Code |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ShaderViewer Class | VisControls Namespace


ShaderViewer Constructor

Initializes a new instance of the ShaderViewer class.

public ShaderViewer();

See Also

ShaderViewer Class | VisControls Namespace


ShaderViewer Properties

The properties of the ShaderViewer class are listed below. For a complete list of ShaderViewer class members, see the ShaderViewer Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
Code |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ShaderViewer Class | VisControls Namespace


Code Property

An NDoc Documented Class Library

ShaderViewer.Code Property

public Code {get; set;}

See Also

ShaderViewer Class | VisControls Namespace


ShaderViewer Methods

The methods of the ShaderViewer class are listed below. For a complete list of ShaderViewer class members, see the ShaderViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ShaderViewer Class | VisControls Namespace


Method

An NDoc Documented Class Library

ShaderViewer. Method

Overload List

Inherited from Component.

public void ();

protected override void (Boolean);

See Also

ShaderViewer Class | VisControls Namespace


ShaderViewer. Method (Boolean)

protected override void (
Boolean disposing
);

See Also

ShaderViewer Class | VisControls Namespace | ShaderViewer. Overload List


Transfer2D Class

For a list of all members of this type, see Transfer2D Members.

System.Object
Transfer2D

public class Transfer2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

Transfer2D Members | VisControls Namespace


Transfer2D Members

Transfer2D overview

Public Instance Constructors

Transfer2D Constructor Initializes a new instance of the Transfer2D class.

Public Instance Properties

ElementCount

Public Instance Methods

AddPoint |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColor |
GetDensity |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue |
RemovePoint |
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteToTexture |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Transfer2D Class | VisControls Namespace


Transfer2D Constructor

Initializes a new instance of the Transfer2D class.

public Transfer2D();

See Also

Transfer2D Class | VisControls Namespace


Transfer2D Properties

The properties of the Transfer2D class are listed below. For a complete list of Transfer2D class members, see the Transfer2D Members topic.

Public Instance Properties

ElementCount

See Also

Transfer2D Class | VisControls Namespace


ElementCount Property

An NDoc Documented Class Library

Transfer2D.ElementCount Property

public ElementCount {get;}

See Also

Transfer2D Class | VisControls Namespace


Transfer2D Methods

The methods of the Transfer2D class are listed below. For a complete list of Transfer2D class members, see the Transfer2D Members topic.

Public Instance Methods

AddPoint |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColor |
GetDensity |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue |
RemovePoint |
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteToTexture |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Transfer2D Class | VisControls Namespace


Transfer2D. Method

public int (
Single density,
UInt32 color
);

See Also

Transfer2D Class | VisControls Namespace


Transfer2D. Method

public uint (
Int32 index
);

See Also

Transfer2D Class | VisControls Namespace


Transfer2D. Method

public float (
Int32 index
);

See Also

Transfer2D Class | VisControls Namespace


Transfer2D. Method

public uint (
Single density
);

See Also

Transfer2D Class | VisControls Namespace


Transfer2D. Method

public void (
Int32 index
);

See Also

Transfer2D Class | VisControls Namespace


Transfer2D. Method

public void (
Texture tex
);

See Also

Transfer2D Class | VisControls Namespace


VisSwapChain Class

For a list of all members of this type, see VisSwapChain Members.

System.Object
VisSwapChain

public class VisSwapChain :

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: VisControls

Assembly: VisControls (in VisControls.dll)

See Also

VisSwapChain Members | VisControls Namespace


VisSwapChain Members

VisSwapChain overview

Public Instance Constructors

VisSwapChain Constructor

Public Instance Properties

PresentParam
SwapChain

Public Instance Methods

Begin |
Dispose |
End |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Present |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VisSwapChain Class | VisControls Namespace


VisSwapChain Constructor

public VisSwapChain(
Device device,
PresentParameters pp
);

See Also

VisSwapChain Class | VisControls Namespace


VisSwapChain Properties

The properties of the VisSwapChain class are listed below. For a complete list of VisSwapChain class members, see the VisSwapChain Members topic.

Public Instance Properties

PresentParam
SwapChain

See Also

VisSwapChain Class | VisControls Namespace


PresentParam Property

An NDoc Documented Class Library

VisSwapChain.PresentParam Property

public PresentParam {get;}

See Also

VisSwapChain Class | VisControls Namespace


SwapChain Property

An NDoc Documented Class Library

VisSwapChain.SwapChain Property

public SwapChain {get;}

See Also

VisSwapChain Class | VisControls Namespace


VisSwapChain Methods

The methods of the VisSwapChain class are listed below. For a complete list of VisSwapChain class members, see the VisSwapChain Members topic.

Public Instance Methods

Begin |
Dispose |
End |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Present |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VisSwapChain Class | VisControls Namespace


VisSwapChain. Method

public void ();

See Also

VisSwapChain Class | VisControls Namespace


VisSwapChain. Method

public void ();

Implements

IDisposable.

See Also

VisSwapChain Class | VisControls Namespace


VisSwapChain. Method

public void (
PresentParameters pp
);

See Also

VisSwapChain Class | VisControls Namespace


Hierarchy

System.Object
Flow.ChannelData ---- System.IDisposable
Flow.FlowData2D ---- System.IDisposable
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.Form
Flow.EditColorGradient
Flow.FlowViewer
System.Windows.Forms.UserControl
Flow.ChannelControls
Flow.GlyphControls
Flow.GPUStreamlinesControls
Flow.MainControls
Flow.StreamLinesControls
System.ValueType
Flow.FlowData2D.TimeStep
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Flow.FlowData2D.DrawMethod
Flow.FlowData2D.IntegrationMethod
Flow.StreamLinesControls.DRAWTYPE

See Also

Flow Namespace


Hierarchy

System.Object
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
VisControls.ScreenshotRenderer.DoRendering
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
System.Windows.Forms.ButtonBase
System.Windows.Forms.RadioButton
VisControls.GlowingRadioButton
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.Form
VisControls.ShaderViewer
System.Windows.Forms.UserControl
VisControls.GroupBoxDrop
VisControls.GroupBoxDropContainer
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
VisControls.Keyboard.VirtualKeyStates
VisControls.Camera
VisControls.Keyboard
VisControls.OffscreenRT ---- System.IDisposable
VisControls.ScreenshotRenderer
VisControls.Transfer2D
VisControls.VisSwapChain ---- System.IDisposable

See Also

VisControls Namespace